Question
Welcome to Ask A Mechanic and welcome to our new website! We are working on the new website and we would like to see you post your feedback here. Could be if you find any bugs or just want to give us tips on what you want us to change!  
solved 1
5 months 1 Answer 2292 views Diagnostic Technician

Question
I had my chevy cruze jumpstarted and after running it for 30 minutes. When it was jump started the check engine light came on and after driving the car I checked what codes popped up and it was p069e and p2535.  I haven’t drove my car since january 23 because I broke my right ankle and was recovering. Does anyone know what the problem is.
in progress 0
6 hours 2 Answers 6 views Member

Question
Hello I have a 2005 Chevy equinox with a 3.4 liter engine in it it over heated and the check engine light came on had the code read and it says cooling system malfunction under that code it consists of thermostat waterpump and cooling sensor I have replaced all 3 and it’s still over heats I am not leaking any antifreeze anywhere nor is any blowing out of my tail pipe nor is any huge clouds of white smoke the only Time I loose antifreeze is when it over heats and the car goes into safety mode and then I am only looking it out of the tank where the antifreeze goes it has that little tank on it that is pressurized as the radiator is a closed system I don’t know what else to do than other start pulling plugs to check for a bad head or I take gasket
in progress 0
7 hours 1 Answer 5 views Member

Question
Good afternoon, I drive a 2009 Mazda 6 Ts2 I took my car for a MOT and the most costly service they provide, there where some repairs, costing a total of over £800. 2/3 weeks later of normal driving, i hear an awful noise from a wheel, i return the car and ask them to check. He tells me that the sliders in the carrier had ‘rotted’ and caused the calipers to seize, this wore down the brake pads because it was holding onto the disks, and this damaged the disks and calipers irreparably. so they need to be replaced. Front and back. This will cost a further £800 He tells me that in their ‘major service’ they checked the brakes but the caliper was OK, so there was no way of quoting it up. because then they would be “over-quoting me and ripping me off”. Now, if the most expensive service they provide couldn’t (didn’t) find this problem, then when would it ever normally be found before it’s too late? I’m thinking that maybe its possible they messed up my brakes during the service or missed this problem, and are trying to cover for it So my main question is, is this a legit unforeseeable problem, or am i being taken for a fool? thank-you.
in progress 0
1 day 1 Answer 16 views Member

Question
When I’m driving in a residential area with a lot of stop signs I have to keep the engine revved up when stopped so it won’t stall but when I’m on a freeway & going for a long time it wont do that. Also, if it stalls sometimes it wont start right away & will have to keep it sitting for a while. My car is a 1980 manuel transmission Volkswagen Vanagon with 127500 miles on it
in progress 0
1 day 1 Answer 6 views Member

Question
Peougeot 308 1.4 petrol 09 plate fault code p1138 combustion cylinder 2 plugs ok coil sticks fine when reading live data on solus scanner injector 2 initially shows a reading then nothing it’s as though it shuts down
in progress 0
2 days 1 Answer 10 views Member

Question
I have a 1997 Mercury Grand Marquis. I had smoke coming from the driver’s side rear tire. I took it to a shop they said it was the wheel bearing. They replaced it on March 12, 2018. on Friday, April 20, 2018, it did it again. now they are saying I need a whole new rear end. Would it not be the bearing again?
in progress 0
2 days 1 Answer 12 views Member

Sorry it private question .

Question
2012 caravan 3.6l? , rear passenger wheel won’t spin when on hoist , rear driver side hard to spin. Can hear scraping noise when driving Don’t smell break pad burning wondering if ebreak is stuck??
in progress 0
4 days 1 Answer 20 views Member

Question
1988 Chevrolet s10 pickup v6 2.8- engine turns over but won’t start. Tried grounding the distributor cable and no spark, but also not delivering any fuel. I couldn’t think of anything else that might control both spark and fuel, so I changed the ecm. Also has brand new ignition coil, spark plugs, spark plug wires, distributor, ignition module, and IAC valve.It does occasionally start and runs fine, but rarely.
in progress 0
4 days 1 Answer 17 views Member

Question
VW Jetta MK4 1.8T AGU engine. Hi there, a quick electrical question regarding the 12v switched power labeled 75x above the foot pedal. The nut holding the bracket for the relays is supposed to be a negative. Then the wiring labeled 75x is supposed to be a switched 12v so when the ignition is turned on then only it supplies 12v. My problem is I have no ground from the nut that holds the relays bracket in place like normal people do and also my 75x has constant power and when the ignition is turned it cuts the power. Its working in reverse. I checked all the fuses and nothing is blown.
in progress 0
4 days 1 Answer 18 views Member