Question
Welcome to Ask A Mechanic and welcome to our new website! We are working on the new website and we would like to see you post your feedback here. Could be if you find any bugs or just want to give us tips on what you want us to change!  
solved 1
5 months 1 Answer 2284 views Diagnostic Technician

Question
My ’96 Ford Ranger 3.0L V6 will not start if it is colder than 45-50 degrees out. I have already replaced the coil pack and the coolant temp sensor(ECT). What else should I check?
in progress 0
7 hours 1 Answer 13 views Member

Question
Hi, I have a Mercedes E500 2003 w211 with airmatic; when parked overnight the rear suspension on the driver side sags, but a few minutes after starting the engine, this rear suspension goes back to normal. However, when the height of the car is raised (it’s one of the feature of the car), this rear suspension never sags (even with the main battery located in the trunk removed), any thoughts on what could have cause this rear suspension from sagging overnight is appreciated. Thanks
in progress 0
15 hours 1 Answer 13 views Member

Question
Hello I have a 2002 Honda Odyssey van. The van cranks but does not start. I put it on a code reader and the only error code that it read was the coolant temperature sensor so I replaced it with a new one and still does not start. I bought it the beginning of January and it did this one other time but ended up starting after two days. This time its been a month and NO start. PLEASE HELP. THANK YOU.
in progress 0
4 days 1 Answer 21 views Member

Question
Good day, I have a Fiat palio 1.2 2009. I recently changed the clutch kit and my car was just never the same again. The first thing I noticed was the sound I could hear when I move up a steep from 1st gear, sounds like an old wheelbarrow . Then the car shakes a lot when I go over 80km/h. The most disturbing by far is this random thing that would just happen whenever – When I was stuck in traffic my car starts to Rev high, then soon the car won’t go into gear. I have to switch off the car for about 10 min while pumping the clutch. When I’m still stuck in the traffic I have to switch on and off my car cos it won’t stay in 1st gear and its the only way to change gears, it shakes uncontrollably and the slightest lift off the brakes makes the car jump. Once I have rested the car for a few munites it will go back to being fine till the next time when it happens again. I have had this happen about 4-5 times in the past month and a half. I have returned it to the garage so many times and when it’s there, it runs fine and they can’t find any problems. I even asked them to ride it for a week and they just cleaned the engine and gave it back. This is frustrating because it happens to me when I’m so far and alone and so randomly that I cannot say what circumstances causes the revving and gears to stop working. Please help me I can’t live like this!!!
in progress 0
6 days 1 Answer 35 views Member

Question
Okay I have a 2004 Mitsubishi Diamante I bought it about a month ago how drove for two weeks and one morning didn’t want to start so I left it until about father afternoon and it started and after that every day after it is same thing everyday no start then later on that day finally starts so changed the fuel filter still wouldn’t start so change the fuel pump still nothing so waited for the fuel pump relays and change that started it perfect sounds great awesome about two hours later sorted storage perfect starts to sputter and dies won’t start again so we change spark plugs spark plug wires and the whole distributor still nothing no sport nothing so far turns over no fire please I’m out of data and I don’t know what to do now
in progress 0
6 days 6 Answers 78 views Member

Question
hello I have a 2006 dodge caravan and I work nights so as soon as I got to work I noticed my gas cap was off when I went to put it back on I noticed that there was some kind of expanding foam in the tank what should I do.
in progress 0
6 days 1 Answer 24 views Member

Question
My 2004 jeep grand Cherokee Laredo 4.0L 2wd gave me 2 strange fault codes this morning and I can’t seem to find any information on them at all. The first code is B2TAE. And the 2nd code is C1202. I haven’t been able to get it to display the codes since it happened the first time. Any information you can provide would be greatly appreciated. Thank you for your time and resources.
solved 0
7 days 1 Answer 36 views Member