Question
Jeepcherokee04
My 2004 jeep cherokee turns off while driving no warnings no light go off my dash stayes on and so does my radio but my steering wheel gets hard and so do my pedals after I try to turn it on it won\’t start it tries but it can\’t I let it sit for a few hours and it starts up like nothing some ties it take days to turn off again and sometimes it happends very often but since it turns on iknow my battery is good and so is my alternator but I don\’t know what it could be maybe my gas pump not pushing enough pressure ?
in progress 0
Jeepcherokee04 4 months 1 Answer 729 views

Question
I am trying to figure out why the alarm wont work because usually when you unlock the door from the inside after locking it the alarm goes off but that doesn’t seem to be happening. I also am trying to figure out how to make the horn chirp and the lights flash when locking it
in progress 0
4 months 2 Answers 738 views Member

Question
Hello mechanics! My fuel flow gets slower and slower. I was told its the evap canister. Does anyone know where its located on a 2006 CTS 2.8L specifically? Obviously it has to be around the gas tank. Cant find it. UPDATE: now my car isnt taking any gas at all! Help!
solved 0
4 months 1 Answer 775 views Member

Question
I drive a 2012 Dodge Journey which has a big problem with foggy interior windows in the winter only. We have to drive with the defrost on full or we can’t see out. The side windows will often get frosty even with the fan on. Any suggestions?
solved 0
4 months 1 Answer 732 views Member

Question
sxrami3
I currently have a 2012 Dodge journey and my check engine light came on. I ran a diagnostic test and the following came back. Throttle actuator control system sudden high airflow detected and v also circuit bank 1. Any help to define what it means and how to fix it and how much for parts and labor. Thank you in advance.
solved 0
sxrami3 4 months 3 Answers 780 views

Question
Bubbajoe123
Our check engine light on 2008 Kia Sorento has been randomly coming on and it loses power. Issue can’t be duplicated. Everything has been replaced and it is still happening. Has been in almost 20 times. Now no more repair attempts can be made bc nothing else to try.
solved 0
Bubbajoe123 4 months 3 Answers 752 views

Question
dszalapski
I have a 2012 nissan altima 2.5s. The abs and traction control lights came on. I had the codes read and the indication was the right rear speed sensor. I replaced the sensor but the lights remain on. Do i have to have the codes cleared or should the lights have gone off after replacing the part?
solved 0
dszalapski 4 months 3 Answers 784 views

Question
JackMcL-MI
2009 Kia Sorento 4×4 SUV. When driving the headlights and dash lights will dim then come back. I replaced the alternator. Battery tested ok at Autozone. Note: After sitting 30+ hours the battery is at 12.47 volts. The inside cigarette lighter only 10.4 volts. Started car and cigarette lighter jumps up to 14.4 Volts. Car starts well and runs well. just the occasional dimming of the lights. So, battery tests ok, Alternator is new and tests ok. Is there another voltage control module??
solved 0
JackMcL-MI 4 months 1 Answer 733 views

Question
My 2006 GMC Envoy makes a “mooing” sound when brakes are applied.  Also there is pressure pushing the brake pedal up and vibrating.  After researching online others had same issue so I took the ABS STABILTRAK fuse/sensor out and VIOLA!! THE SOUND IS GONE!! Problem is after putting it back in it is STILL there. So what needs to be changed?? I already changed the wheel barring and the brakes look good. What is causing this?? I don’t mind  leaving the fuse out and using regular brakes but with winter approaching I would feel safer with my STABILTRAK on!!
solved 0
4 months 1 Answer 732 views Member

Question
please help I have 2006 one owner VW gti 2.0 I’m throwing four codes p0171 system took lean this codes is first and last on my code list p0456 evaporative emissions  system leak detected (very small leak) p0507 idle air control system RPM HIGHER than expected any input
solved 0
4 months 7 Answers 774 views Member

Question
My 08 dodge nitro\’s heat stopped blowing hot. We had the heater core replaced for $500 and it worked fine for about a week. Then it started overheating and the thermostat was not moving from C so we replaced the thermostat and the coolant and the thermostat seems to work fine now. Heat is still cold and will randomly blow hot when driving above 55. Any help would be appreciated!
solved 0
4 months 1 Answer 726 views Member

Question
My truck just crapped out on me. There was some popping noise under the hood and it turned off on me. I tried to start it up and I heard a loud screeching noise and smelled smoke
solved 0
4 months 1 Answer 739 views Member