Question
BETHY7872
97 Honda Accord LX. Car overheating, but not constantly. Replaced the radiator cap because it was bad. Seems to be losing water, but only when it is sitting and not driving it. Overheats when its at an idle and cools as I drive it. It will be fine, and with no warning it goes from being cool to the temp guage shooting up to the red with no warning. I noticed that the fans will start to stay on after turning the ...
solved 0
BETHY7872 2 weeks 1 Answer 109 views 0

Question
samiramsis03
I have hyundai sonata 2014 YF. I have no cruise control on this car at the moment and even there is no option on the steering control for cruise. I want to know if I replace steering wheel with the one with cruise control on it and replace the wiring harness inside the steering wheel will it work? Are these cars already equipped with cruise option module in the steering wheel and can replacing a steering wheel make it work?
in progress 0
samiramsis03 2 weeks 1 Answer 115 views 0

Question
mamenic
My car is 11 years old (Kia Rio5 2006) but it has always started in bitterly cold weather in the past. I live in Canada. And I don’t even have a block heater. But in the last month, I’ve been having problems where it doesn’t start when it gets really cold. It’s usually after it sits for two or three days without being used but in the past, it would start even if it sat for a couple of days in ...
in progress 0
mamenic 2 weeks 1 Answer 110 views 0

Question
Fred Dro Warner
I have a 2011 GMC Terrain, with a V6 3.0 engine and I am trying to change the spark plugs and trying to get info on how to take off the intake manifold so that I can get to the back spark plugs.
in progress 0
Fred Dro Warner 2 weeks 1 Answer 106 views 0

Question
Phillip Barnhart
I have a 1999 chevy suburban with 350 engine. It will start with starting fluid but will not stay running. Fuel pump is new and working but not getting enough fuel to engine. Dont not have a fuel pressure gauge. But it.doesn\’t have much pressure at the pressure valve on top of engine. Could it be a stopped up fuel filter or frozen lines or filter. It will run as long as i put starting fluid in it. Not sure what else ...
in progress 0
Phillip Barnhart 2 weeks 1 Answer 115 views 0

Question
battery light on. Replaced alternator and battery. Checked with voltmeter says 11.2 with blower on and off. Temps in single digits is it charging or need to replace alternator?
in progress 0
2 weeks 5 Answers 158 views Member 0

Question
Amandap4
my mother had a tire replaced today amd before the replacement there was no pulling and now that it has been replaced it is pulling to the bad something terrible and is very dangerous. What could be causing this? I feel like the tire place did something wrong
solved 0
Amandap4 2 weeks 1 Answer 113 views 0

Question
hihello
I installed a new stereo in my 05 impala and now it won’t start. I put the old stereo back in and it still doesn’t start. it doesn’t click or try to turn over or anything. the lights and radio turn on but none of the instruments move and the message center constantly cycles through the battery, security, low fuel, low coolant, and service engine soon messages.
solved 0
hihello 3 weeks 3 Answers 199 views 0

No Posts Found.

Question
Brandin001
I would like to buy a 2004 Mazda 6 from someone, but they say there is a problem they can\’t figure out and that is why the price is low. the car must be ran at 3000 rpm any lower and the engine chokes. Is this a symptom of a potentially large issue or can it be fixed with minor work? Thank you for your help.
solved 0
Brandin001 1 month 1 Answer 173 views 0

Question
my 1998 ford expedition 4×4. I just replaced the hub on the passenger side front wheel, it ran fine for a few days then the wheel locked up it drives fine in reverse and forward untill I hit the brake then it locks up
solved 0
1 month 2 Answers 172 views Member 0

Question
dszalapski
I have a 2012 nissan altima 2.5s. The abs and traction control lights came on. I had the codes read and the indication was the right rear speed sensor. I replaced the sensor but the lights remain on. Do i have to have the codes cleared or should the lights have gone off after replacing the part?
solved 0
dszalapski 1 month 3 Answers 171 views 0

Question
Arvydas
Hello, My clutch pedal went soft, mechanic found ot eas leaking slave cylinder, but been told i should change clutch too because it will be full of oil, and if i won\’t change it now i will have to replace clutch and flywheel soon. Is that how it should be done? Thank you
solved 0
Arvydas 1 month 1 Answer 170 views 0

Question
please help I have 2006 one owner VW gti 2.0 I’m throwing four codes p0171 system took lean this codes is first and last on my code list p0456 evaporative emissions  system leak detected (very small leak) p0507 idle air control system RPM HIGHER than expected any input
solved 0
1 month 7 Answers 169 views Member 0

Question
sxrami3
I currently have a 2012 Dodge journey and my check engine light came on. I ran a diagnostic test and the following came back. Throttle actuator control system sudden high airflow detected and v also circuit bank 1. Any help to define what it means and how to fix it and how much for parts and labor. Thank you in advance.
solved 0
sxrami3 1 month 3 Answers 165 views 0

Question
Aman oberoi
Strange noise is coming from my volkaswagen Polo. It sounds like friction of some tyres connecting rodes. Because it doesn\’t come when I start the engine, but when I release the accelerator then this noise is coming.
solved 0
Aman oberoi 1 month 1 Answer 162 views 0

No Questions Found.