Question
rickblack
2003 Chrysler Town and Country LX, FWD, 3.3. We had the tie rod end on the passenger side break/shear/snap off on the top half. I used an angle grinder to cut off the remaining top half of the bolt to make it smooth. The problem lies with the bottom half of the bolt where the nut is still attached. Do I use the grinder again and just cut the nut and bottom half of the bolt off then use an air hammer to try and push the remaining bolt still inside the knuckle out? Any help here would be greatly appreciated
in progress0
1 week1 Answer19 viewsMember

Question
Shea
Hi, I just bought a 2006 Ford Mustang 4.0 (basic). I can feel every bump in the road and wonder what can be done to improve the suspension. I’ve been doing some research and asked questions regarding coilovers, struts, shock absorbers, and springs. I’m still not sure what combination of items I need. The only thing I know for sure is that I would like OEM parts if possible to bring to a mechanic to replace all the old parts (if neccesary). And is there an all-in-one package that is not super expensive?
in progress0
4 weeks1 Answer36 viewsMember

Question
pault
Hi, I have a Mercedes E500 2003 w211 with airmatic; when parked overnight the rear suspension on the driver side sags, but a few minutes after starting the engine, this rear suspension goes back to normal. However, when the height of the car is raised (it’s one of the feature of the car), this rear suspension never sags (even with the main battery located in the trunk removed), any thoughts on what could have cause this rear suspension from sagging overnight is appreciated. Thanks
in progress0
1 month1 Answer35 viewsMember

Question
roy ilagan
My car steering rack and pinion assembly and shock absorbers was recently changed with new one. After replacement, wheel balancing was done. Then I drove the car and vibration occurs during turning left or right which is not happening before replacement. What could be the cause of this vibration?
in progress0
1 month1 Answer38 viewsMember

Question
titang9
I’m a Toyota mechanic. A friend has a 2010 535i GT (F07). The Rear Suspension Air Pump works and has pressure (blows air) (short black air line across the pump), however, the leveling valve, the one who has the two air lines (blue and red) for the two rear air spring bags, does NOT blow any air? Any ideas?
solved0
2 months2 Answers94 viewsMember