Question
Rilwn
I own a Opel Astra 1.4 sxi sport (90bph) I had a Engine light showing for my egr valve so I ordered a new one when I tried removing the valve for my car oil started leaking out From what I looked up online I couldn’t find anything to say if oil was meant to be leaking i screwed the bolts back on to stop the oil leaking could anyone pls tell me what I should do or is it normal for oil to be leaking
in progress0
4 hours1 Answer4 viewsMember

Question
Bob
My daughter drives my one owner 2001 Chrysler PT Cruiser (4 cylinder). A week ago she picked up a rock or something and developed a hole in the radiator. I took it to my mechanic who replaced the radiator and the hoses. A week later she drove home from school and stated that white smoke was coming from front hood (coolant smell) and the temperature gauge was at max. I opened hood and noted that the overflow tank was empty, but radiator still full. She said for the week since the new radiator was installed she heard a gurgling sound from under the hood after she would stop the car. Any thoughts certainly appreciated.
in progress0
4 hours1 Answer5 viewsMember

Question
filip99
( Sorry, I am not very steady in English, but hope you understand.) Brand: Hyundai Model: Accent 1997 Engine: 1.5 L L4 SOHC 12 valves (I think)   The problem with the car is that the shifter wont shift into 2nd gear. The problem occured when I was driving over a long distance. The gears on the shifter which is facing the rear of the car (2, 4 & Reverse) stopped working. I could somtimes get it into the 2nd and 4th gear depended on the RPM. But it would rearly go in gear, and just slipped into neutral. Later, I sort of fixed the problem. I adjusted the shift linkages under the shiftstick and got the gears to work. I mounted the bolts tight and secure to prevent them from being adjusted by vibrations and such. But after a little trip with the car, the gears went back to not work. This happens over and over again. I adjust the shift linkages, and some of the gears work, but the problem is always comming back. The 4th gear and reverse are almost always working now, but tend to be problematic on longer roadtrips. The 2nd gear is never working now. I can’t get it into the 2nd gear even after I have re-adjusted the shift linkages. I don’t know if it could be better adjusted in the gearbox or if it is just worn out transmission gear and teeth. Things I’ve tried: -Adjusting the shift linkages and mounting the screws tightly. -Filled with servosteering oil since it was low.   The car is about 20 years, but have only gone 90 000 km. It has some rust at the bottom of the rear, but not much.  Thanks for helping, I really appereciate it. Best regards Filip.
in progress0
4 hours1 Answer13 viewsMember

Question
Flash9803
4.6L 2008 mustang gt car is left on neutral idling and you can hear some ticking noises coming from the front near driver side tire. Any idea on what it could be ? I initially thought it was a lifter but not 100% positive.
in progress0
1 day1 Answer7 viewsMember