Alternator problem?

1 Star2 Stars3 Stars4 Stars5 Stars (1 votes, average: 5.00 out of 5)
Loading...

So this is what’s happening:  1.  Belt (not sure which) has been whining when first start driving and at random times while driving.  The belts were all replaced less than 3 years ago.

2. When trying to turn at slow speeds, especially when engine isn’t fully warmed up, the battery light flickers on and I lose power steering.  Car does not die though.

3. Couple of days ago while driving home after dark I noticed the dash lights getting dim.  Then the battery light started to flicker on.  I pulled the car over and it died.  Battery was dead.  This battery is less than six months old.  Jump started it, barely moved and it went dead again.  Charged it for about 20 minutes and got it home.  (Less than 2 miles home).  Next day we put it on a battery charger and tightened a somewhat loose alternator belt.  All the belts look great.  The next day I drive it around all day no problem but starts to die again on the way home.  I keep going since Im almost home but then it seems like the dying stops.  Get home and everything seems fine.  Shut the car off and start it again a few times.  Put it on the charger all night.  No problems the next day.  Didn’t drive it all day the next day after that.  Today it started right up.  Took it to autozone to test the alternator and they said they couldn’t test it cause the battery was only at 54%. So that’s where Im at now.  Any opinions would be appreciated.  This is a 2004 Elantra.

solved 0
Hollyad76 4 months 1 Answer 994 views Member 0

Answer ( 1 )

  1.  

    Hello hollyad.

    Let the engine idle and give power to all consumers inside the car, max fan, lights, heated mirror, heated rear screen, heated seats.

    Measure the voltage between the battery terminals. If you have under 12.5 volt then try to give the alternator a punch with a hammer and see if the voltage rise up when you doing that.
    If its doing that the coals inside the alternator is probably worn out.

    If not try to put a jumper cable between engine and chassi, chassi and battery terminal, try to see if you could see the voltage to rise, then you can see if you got bad earth somewhere.

    🙂

    Best answer

Leave an answer

Browse
Browse

Captcha Click on image to update the captcha .

About Hollyad76Member