Car isn’t starting in cold weather Kia Rio 2006

1 Star2 Stars3 Stars4 Stars5 Stars (1 votes, average: 5.00 out of 5)
Loading...

My car is 11 years old (Kia Rio5 2006) but it has always started in bitterly cold weather in the past. I live in Canada. And I don’t even have a block heater. But in the last month, I’ve been having problems where it doesn’t start when it gets really cold. It’s usually after it sits for two or three days without being used but in the past, it would start even if it sat for a couple of days in really cold weather. During this past month of having this problem, I got it to start when the weather would get a bit milder and one time I had it boosted. On Wednesday, I finally got a new battery and it worked okay on Thursday. But Friday (yesterday), I didn’t use it… and now today, it doesn’t start again, even with a new battery. I’m wondering what else can cause it to not start like this in cold weather? It not a click sound… it’s like it’s trying but not turning over.

in progress 0
mamenic 3 months 1 Answer 748 views 0

Answer ( 1 )

  1. Hello

    It could be some part that is draining the battery.

    But because it’s a very common problem on KIA is the ground cable beween battery and chassi, I would have removed it both from battery and chassi and clean it up and scrape the chassi part so it gets good ground.

    Make sure you have one door open so the car does not lock when you are fitting the cable again.
    It’s worth a try and very cheap fix 🙂

     

Leave an answer

Browse
Browse

Captcha Click on image to update the captcha .