Welcome Guest. Sign inor Signup

4 Answers

Having to boost my car for it to start then runs fine Mustang GT

Asked by: 13 views Electric Question

Started my car this morning and it hesitated, but started, threw the wrench light but drove ok…stopped after 15 min turned it off and started it back, no wrench light and driving fine, it sat in the parking lot at work for about 3 hours I drove it 30 min stopped got gas, then it wouldn’t start. Had to crank it twice. Then drove 10 min and I had to boost it in order for it to start that time…it’s a 2010 Mustang GT

Facebooktwittergoogle_plusredditpinterestlinkedinmail

4 Answers

  1. 0 Votes Thumb up 0 Votes Thumb down 0 Votes

    When it’s not starting, is it cranking or nothing?

    If it’s cranking but not starting, you should check the trouble code memory for any trouble codes. A Crankshaft or camshaft sensor is a common problem when the car is not starting sometimes. But check the trouble codes first before replacing any parts

    If it doesn’t crank you may have a worn starter that needs a lot of power to crank. Could also be a bad ground wire between the engine and body.

    Ask A Mechanic Admin - May 29, 2018 |Reply

  2. 0 Votes Thumb up 0 Votes Thumb down 0 Votes

    The first start this morning, it hesitated like a drained battery, the second time it turned over but didn’t start then no power, then waited a min tried again it started. Then 15 min later it was trying to start…it was turning over but then it was like a dead battery, hooked cables to it, it fired right up and i drove home. Waited 10 min tried it and it was like nothing ever happened

    Shortcake89 - May 29, 2018 |Reply

  3. 0 Votes Thumb up 0 Votes Thumb down 0 Votes

    Okay it could be a bad car battery.
    But I can recommend checking the voltage at idle with a multimeter. It should be over 13 volts at idle, if it’s lower you most likely have a worn alternator!

    You can also check the ground cables between the engine and body.

    Ask A Mechanic Admin - May 31, 2018 |Reply

  4. 0 Votes Thumb up 0 Votes Thumb down 0 Votes

    it was the battery, got a new one and he’s good as new…thank you

    Shortcake89 - May 31, 2018 |Reply


Answer Question